eZ Platform Discussions

Try to QuickStart ez platform on server, but end with yarn error: error webpack@4.35.2: The engine "node" is incompatible with this module. Expected version ">=6.11.5". Got "6.11.3"

Hi!

I run a ez publish site for years. Now it´s time to start all over again, so I decide to give ez platform chance.

Installing local was not the problem, but I´m currently not able to get it run on my providers server (Debian).

My steps so far:

I downloaded ezplatform-2.5.2.tar.bz2

I unpacked it and follow Quick installation guide. ( https://doc.ezplatform.com/en/2.4/getting_started/quickstart/ )

After that I run:

composer create-project --keep-vcs ezsystems/ezplatform .

This runs well without memory or timeout error until “>yarn install”.

There comes an error and all stopped:

yarn install
yarn install v1.17.3
[1/4] Resolving packages…
[2/4] Fetching packages…
error webpack@4.35.2: The engine “node” is incompatible with this module. Expected version “>=6.11.5”. Got “6.11.3” error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
Script yarn install handling the symfony-scripts event returned with error code 1
Script @symfony-scripts was called via post-install-cmd

Did dont patch anything, all scripts are out of the box.

Can´t find anything about this error in web or this forum.

Can you help?

Thanks,
Kai

Hi @kais!
What is your NodeJS version? We recommend using Node.js 10.15.3 (LTS) with eZ Platform 2.5.2.
You can see the whole requirements here: https://doc.ezplatform.com/en/2.5/getting_started/requirements/

Hi Mnocon,

thanks for your help. Thats exactly what happend. NodeJS Version was too low.

Thanks,
Kai