eZ Platform Discussions

Problems migrating from ezpublish 5.4: wrong versions of db update script, ezplatform-xmltext-fieldtype


#1

Dear community,

we’re trying to update our 2014.11/5.4 eZpublish installation to latest eZ Platform. The docs in different versions state that we should use 1.7 as a first stepstone¹ but if we extract the available 1.7.6 LTS archive

  1. ezplatform-xmltext-fieldtype ^1.3.0` is not installable² and
  2. the mentioned db-update script “dbupdate-5.4.0-to-6.13.0.sql” is not included.

What is the preferred migration/upgrade path?

And if we follow the recommendation to migrate in stages, when should we call the xmtext-migration script? In 1.7.6 it is in a very old beta stage.

Any help would be appriciated, thanks in advance // nielo

¹) https://doc.ezplatform.com/en/1.13/migrating/migrating_from_ez_publish_platform/#step-1-extract-ez-platformenterprise-v17
²) Installation request for ezsystems/ezplatform-xmltext-fieldtype ^1.3.0 -> satisfiable by ezsystems/ezplatform-xmltext-fieldtype[1.7.0, v1.3.0, v1.4.0, v1.5.0, v1.5.1, v1.6.0, v1.6.1, v1.6.2, v1.7.1, v1.7.2, v1.7.3, v1.8.0, v1.8.1, v1.8.2, v1.9.0].