eZ Platform Discussions

Problem installing Kaliop/MigrationBundle (because of nikic/php-parser v3.1.1 ?)


#1

Hi,

I meet trouble to install “kaliop/ezmigrationbundle”: “^3.0”.

Here is some details of my ezplatform instance packages versions:

ezplatform v1.12
symfony v3.3.10
legacy-bridge v1.4.0.1
netgen/admin-ui-bundle v2.0.3
...
(and specifically) nikic/php-parser v3.1.1

Here is my command line output:

myuser@myhost:/mypath/to/ezplatform$ php ../composer.phar update kaliop/ezmigrationbundle
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.
  Problem 1
    - Conclusion: don't install kaliop/ezmigrationbundle 3.6.3
    - Conclusion: don't install kaliop/ezmigrationbundle 3.6.2
    - Conclusion: don't install kaliop/ezmigrationbundle 3.6.1
    - Conclusion: don't install kaliop/ezmigrationbundle 3.6.0
    - Conclusion: don't install kaliop/ezmigrationbundle 3.5.0
    - Conclusion: don't install kaliop/ezmigrationbundle 3.4.0
    - Conclusion: don't install kaliop/ezmigrationbundle 3.3.0
    - Conclusion: don't install kaliop/ezmigrationbundle 3.2.2
    - Conclusion: don't install kaliop/ezmigrationbundle 3.2.1
    - Conclusion: don't install kaliop/ezmigrationbundle 3.2.0
    - Conclusion: don't install kaliop/ezmigrationbundle 3.1.0
    - Conclusion: don't install kaliop/ezmigrationbundle 3.0.3
    - Conclusion: don't install kaliop/ezmigrationbundle 3.0.2
    - Conclusion: don't install kaliop/ezmigrationbundle 3.0.1
    - Conclusion: remove nikic/php-parser v3.1.1
    - Installation request for kaliop/ezmigrationbundle ^3.0 -> satisfiable by kaliop/ezmigrationbundle[3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.3.0, 3.4.0, 3.5.0, 3.6.0, 3.6.1, 3.6.2, 3.6.3].
    - Conclusion: don't install nikic/php-parser v3.1.1
    - kaliop/ezmigrationbundle 3.0.0 requires nikic/php-parser 2.* -> satisfiable by nikic/php-parser[v2.0.0, v2.0.1, v2.1.0, v2.1.1].
    - Can only install one of: nikic/php-parser[v2.0.0, v3.1.1].
    - Can only install one of: nikic/php-parser[v2.0.1, v3.1.1].
    - Can only install one of: nikic/php-parser[v2.1.0, v3.1.1].
    - Can only install one of: nikic/php-parser[v2.1.1, v3.1.1].
    - Installation request for nikic/php-parser (locked at v3.1.1) -> satisfiable by nikic/php-parser[v3.1.1].

Does it mean I need to uninstall nikic/parser v3.1.1 and install v2.1.1 ?
If yes, with composer command line or by reconfiguring composer.json ?
(I’m not yet at ease for such operations)

Thanks for advice.


#2

Hello.

Any specific reason for you to try to use Migrations Bundle v3 ?
Version 4 has been out now for more than a month, and we are already at version 4.3.0.
It is also compatible with nikic/parser v3


#3

Hello,
Thank you for your reply and to correct me.
I’ve made the error because I’ve read the Readme which is still in Installation “kaliop/ezmigrationbundle”: “^3.0”.

In the meanwhile I’ve updated my composer.json and upgraded my ezplatform instance to kaliop/ezmigrationbundle v4.3.0 + nikic/parser v3.1.2

By the way, I’m often confused between Github and Packagist. Please help me for my understanding.
I thought Packagist was synchronized from Github (authoritative source).
. On Github the following versions are displayed: master + stable 1.x + stable 2.x + stable 3.x + future 4.x;
. Whereas on Packagist the following version are displayed: all versions until 4.3.0
May be I’m totallly wrong !!?


#4

Thx for letting me know, I will fix the readme.

As for Packagist and github: Github does notify Packagist. Packagist has no other source of info than Github.

Otoh when you are looking at Github, you should look at the ‘releases’ page (https://github.com/kaliop-uk/ezmigrationbundle/releases). You have been looking at the ‘branches’ page (https://github.com/kaliop-uk/ezmigrationbundle/branches), which lists all existing branches in the source code. Releases generally correspond to tags in the source code, not to branches.


#5

Thanx !
Better clear for me now