eZ Platform Discussions

Post your eZ Platform Bundle


#1

Hello eZ Community!

Several months ago, we added a new section on ezplatform.com: https://ezplatform.com/Bundles :package:
On this page, you can find bundles compatible with eZ Platform only.

If your bundle is not listed and you would like to make it visible for the eZ Community, it’s easy! Just post a comment below and we’ll add your bundle to the list.


#2

Hard to number them all :slight_smile:


#3

https://packagist.org/packages/contextualcode/platformsh-siteaccess-matcher-bundle


#4

Hey, I think you can add:


#5

Hello Everyone!

Would you be so kind as to add:

https://packagist.org/packages/brookinsconsulting/bcdocumentreaderbundle
https://packagist.org/packages/brookinsconsulting/bcpagedatabundle

https://packagist.org/packages/brookinsconsulting/bcpagelayoutoverridetestbundle
https://packagist.org/packages/brookinsconsulting/bcerrorpagesbundle

https://packagist.org/packages/brookinsconsulting/bclowercaseurlaliasbundle
https://packagist.org/packages/brookinsconsulting/bcremovetranslationbundle

Cheers,
Brookins Consulting


#6

@Plopix @Serhey sorry for the late reply. We have been busy to fix some issues regarding the bundle page on ezplatform.com. We have some improvements coming regarding the update of the list.
I added your bundles to the list.

@Serhey: the description on packagist.org mentions that this bundle is for eZ Publish. On ezplatform.com, we would like to only have bundles that are compatible with eZ Platform. If your bundle is compatible with eZ Platform (and I guess it is), could you please update the description on packagist and replace eZ Publish by eZ Platform? Also @bdunogier recommended to use the tag ezplatform-bundle.


#7

Hello @brookinsconsulting!

Thanks for creating and submitting your bundles.

On my previous message, I was explaining that on ezplatform.com we would like to have only content (blog posts, bundles, discussions, documentation…) regarding eZ Platform. We took this decision to not confuse developers and users. We finally draw a line between the websites.

It seems that your bundles are for eZ Publish Platform (as far as I understood with the description). If they are pleas submit them on projects.ez.no, I will be happy to approve them. If they are for eZ Platform, please comment and I will add them to ezplatform.com.

Thanks.


#8

@sylvain.guittard done. Please let me know if any other changes are required.
Also if eZ Platform would like to support Platform.sh from the box, this bundle could be added to the core. Here is an example when it is useful:
You have eZ Platform project with multiple siteaccess, which runs on Platform.sh:

And those URLs will not be mapped to any siteaccess, so default one will be used for each of that stage env URLs. It means fr—site—com—%ENV%-%REGION%-%PLATFORM_PROJECT_ID%.us.platform.sh will open “en” (but not “fr”) siteaccess. But if you install this bundle, fr—site—com—%ENV%-%REGION%-%PLATFORM_PROJECT_ID%.us.platform.sh will open fr siteaccess.

The only option without this bundle is to manually modify stage env siteaccess match parameters. Which might be a huge pain if there are tons of siteaccesses in your project.


#9

@Serhey: this bundle makes totally sense and can definitely be added to the core. eZ Platform Cloud will use platform.sh (https://ez.no/Blog/We-Are-Launching-eZ-Platform-Cloud-Speeding-Up-Development-of-Your-Projects).

As a product manager, I will keep this in mind.
Thanks again.


#10

@sylvain.guittard : The bundles we posted are for eZ Platform. They do not require eZ Publish Legacy. Noted that they are older bundles and could do with a documentation refresh they are targeted for eZ Platform Compatibility.

Let us know when you have posted bundles noted here so that we can bask in acceptance :slight_smile:

Cheers,
Brookins Consulting