eZ Platform Discussions

"Not Acceptable"


#1

Since the 2.5 update, I have a “Not Acceptable” error on admin.

image

It is caused by an ajax request:

POST https://staging.admin.site1.com.c.myproject.ent.platform.sh/api/ezp/v2/location/tree/load-subtree

LoadSubtreeRequest{
    _media-type: application/vnd.ez.api.ContentTreeLoadSubtreeRequest
    nodes[
        0: {
        _media-type: application/vnd.ez.api.ContentTreeLoadSubtreeRequestNode,
        children: [
            0: {
                _media-type: application/vnd.ez.api.ContentTreeLoadSubtreeRequestNode,
                children: [],
                limit: 30,
                locationId: 66393,
                offset: 0
            }
        ],
        limit: 30,
        locationId: 59,
        offset: 0
        }
    ]
}

ezpublish.yml

ezpublish
    system:
        site1_group:
            content:
                tree_root:
                    location_id: 59

Response :

ErrorMessage	{
    _media-type	application/vnd.ez.api.ErrorMessage+json,
    errorCode	406,
    errorMessage	Not Acceptable,
    errorDescription	L'argument '$content' est invalide : Location 17020 has missing Content
}

https://staging.admin.site1.com.c.myproject.ent.platform.sh/content/location/17020

500 Error
L’argument ‘$content’ est invalide : Location 17020 has missing Content

If I empty the caches, the problem is temporarily solved.

But it always reappears in the end.


#3

This is probably due to the fact that my three servers each have their own cache folder.