eZ Platform Discussions

[Need help] Symfony Local does not change when switching siteaccess


#1

Hi all,

I don’t know why symfony local es always “en_GB” when switching siteaccess.

Here is my ezplatform.yml configuration:

Thanks!


#2

I’m still looking for a solution, any idea?


#3

I ran into this same exact issue a few months ago. I believe if you remove this line:

line 50:  languages: [eng-GB, fre-FR, esp-ES]

That should fix your issue.

Basically what I think is happening is your site_group is defining the language order and then in your siteaccess the rules for language is not overriding the group language setting.

Try commenting out line 50 and see what happens.


#4

Thank you @travis.raup this solved my problem!

Do you know how to share session between my siteaccess? to avoid user login again while switching language?


#5

We are doing that too.

system:
        site_group:
            session:
                cookie_lifetime: 86400
                name: site_session
        admin_group:
            session:
                 name: site_session

I believe you put the session cookie name in the group setting instead of the individual siteaccess setting.

We also share the session between the site_group and admin_group. We did that so the page_builder preview would work. At least I think that was the reason. Something with the page builder was failing when the site_group and admin_group used different session names.


#6

It works great, thank you again @travis.raup !