eZ Platform Discussions

Inodes issue on server resolved by clearing ezplatform prod cache


#1

CheckMK monitoring system reports:

CRIT - 10.9% used (10.87 of 100.00 GB), trend: +1.40 GB / 24 hours, inodes available: 94k/4.99% - less than 5.00% inodes available(!!) 

Is there a configuration setting I should be considering to ensure that ez does not exhaust availble inodes on an ubuntu server? I am running ez platform 2.3.

When I clear the var/cache/prod the issue is resolved.

I can see there was an issue on symfony regarding an endless growing of session files: https://github.com/symfony/symfony/issues/10349


#2

I found someone on the server had set session.gc_probability = 0.

In combination with the above link, i think this was the cause. I could not find any reference to inodes in the ez docs, don’t know if it would be worth a short mention for anyone else who stumbles upon this in the future?


#4

OK, I am still experiencing ever growing inode issues due to the

var/cache/prod/http_cache/ez

I have the default php garbage collection settings now set in the

/etc/php/7.1/fpm/php.ini

But the inode on the server df -i keeps growing and growing.

The apache config is set to use the default symfony caching proxy:

    # Optional: Whether to use Symfony's builtin HTTP Caching Proxy.
    # Disable it if you are using an external reverse proxy (e.g. Varnish)
    # Possible values: 0, 1 or ""
    # Defaults to disabled if SYMFONY_ENV is set to "dev" or SYMFONY_TRUSTED_PROXIES is set,
    # and if this env value is omitted or empty
    SetEnv SYMFONY_HTTP_CACHE 1

Anyone out there know how to resolve this, or is the only real option to either:
a) keep clearing the cache by cron
b) use varnish

Thanks,
John

(or is this related to this servers use of php-fpm vs ez/symfony?)