eZ Platform Discussions

HWIOAuthBundle / BeSimpleSsoAuthBundle - Composer errors


#1

In parallel with the dev of my own connector, I test the Symfony bundle proposed in the eZ doc.

HWIOAuthBundle

composer require hwi/oauth-bundle php-http/guzzle6-adapter php-http/httplug-bundle

[RuntimeException]
Could not delete /var/www/composer_cache/files/symfony/event-dispatcher/49cc2a6541c6d289745e4b85d0104f10756b47f5.zip:

composer update

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for hwi/oauth-bundle ^0.6.3 -> satisfiable by hwi/oauth-bundle[0.6.3].
- hwi/oauth-bundle 0.6.3 requires php-http/httplug ^1.0 -> satisfiable by php-http/httplug[v1.1.0, v1.0.0].
- Can only install one of: php-http/httplug[v2.0.0, v1.1.0].
- Can only install one of: php-http/httplug[v2.0.0, v1.1.0].
- Can only install one of: php-http/httplug[v2.0.0, v1.0.0].
- php-http/guzzle6-adapter v2.0.0 requires php-http/httplug ^2.0 -> satisfiable by php-http/httplug[v2.0.0].
- Installation request for php-http/guzzle6-adapter ^2.0 -> satisfiable by php-http/guzzle6-adapter[v2.0.0].

My composer.json :

        "php": "^7.1",
        "symfony/symfony": "^3.4.2",
        "twig/twig": "^1.0||^2.0",
        "twig/extensions": "^1.5.1",
        "symfony/assetic-bundle": "^2.8.2",
        "symfony/swiftmailer-bundle": "^3.2.2",
        "symfony/monolog-bundle": "^3.3.0",
        "doctrine/doctrine-bundle": "^1.9.1",
        "doctrine/orm": "^2.5",
        "sensio/distribution-bundle": "^5.0.22",
        "incenteev/composer-parameter-handler": "^2.1.3",
        "ezsystems/ezpublish-kernel": "~7.3.0",
        "ezsystems/repository-forms": "~2.3.0",
        "ezsystems/ezplatform-solr-search-engine": "~1.5.4",
        "ezsystems/ez-support-tools": "~0.2.1",
        "ezsystems/ezplatform-http-cache": "~0.8.0",
        "ezsystems/ezplatform-admin-ui": "~1.3.0",
        "ezsystems/ezplatform-admin-ui-modules": "~1.3.0",
        "ezsystems/ezplatform-admin-ui-assets": "~3.1.0",
        "ezsystems/ezplatform-design-engine": "~2.0.0",
        "ezsystems/ezplatform-standard-design": "~0.1.0",
        "ezsystems/ezplatform-cron": "~2.0.0",
        "ezsystems/date-based-publisher": "~3.1.0",
        "ezsystems/flex-workflow": "~3.1.0",
        "ezsystems/ezplatform-page-fieldtype": "~1.1.0",
        "ezsystems/ezplatform-page-builder": "~1.1.0",
        "ezsystems/ezplatform-form-builder": "~1.0.0",
        "ezsystems/ezplatform-ee-installer": "~2.3.0",
        "ezsystems/ezplatform-http-cache-fastly": "~1.1.1",
        "knplabs/knp-menu-bundle": "^2.2.1",
        "willdurand/js-translation-bundle": "^2.6.6",
        "friendsofsymfony/jsrouting-bundle": "^1.6.3",
        "white-october/pagerfanta-bundle": "^1.2",
        "gregwar/captcha-bundle": "^2.0",
        "roave/security-advisories": "dev-master",
        "leafo/scssphp": "^0.7.6",
        "symfony/thanks": "^1.0.7",
        "ezsystems/ezplatform-xmltext-fieldtype": "^1.5",
        "kaliop/ezmigrationbundle": "^4.6",
        "whiteoctober/breadcrumbs-bundle": "^1.4",
        "ezsystems/legacy-bridge": "^2.0",
        "netgen/ez-forms-bundle": "^2.0",
        "netgen/richtext-datatype-bundle": "^1.1",
        "excelwebzone/recaptcha-bundle": "^1.5",
        "lolautruche/ez-core-extra-bundle": "^2.1",
        "ezplatform-i18n/ezplatform-i18n-fr_fr": "^2.2",
        "edgar/ez-uitreemenu-bundle": "^0.3.6",
        "edgar/ez-uicontentsbytype-bundle": "^1.1",
        "hwi/oauth-bundle": "^0.6.3",
        "php-http/guzzle6-adapter": "^2.0",
        "php-http/httplug-bundle": "^1.13"

Does anyone have any feedback on this bundle?
@tore.minsaas Have you solved your problem? (HWIOAuthBundle and Platform v.2.1)

Merci.


#2

BeSimpleSsoAuthBundle

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for besimple/sso-auth-bundle @dev -> satisfiable by besimple/sso-auth-bundle[dev-master, 1.0.x-dev].
- Conclusion: remove kriswallsmith/buzz 0.17.2
- ezsystems/ezpublish-kernel v7.3.1.1 requires kriswallsmith/buzz ^0.17.2 -> satisfiable by kriswallsmith/buzz[0.17.2].
- ezsystems/ezpublish-kernel v7.3.1.1 requires kriswallsmith/buzz ^0.17.2 -> satisfiable by kriswallsmith/buzz[0.17.2].
- ezsystems/ezpublish-kernel v7.3.2 requires kriswallsmith/buzz ^0.17.2 -> satisfiable by kriswallsmith/buzz[0.17.2].
- ezsystems/ezpublish-kernel v7.3.1 requires kriswallsmith/buzz ^0.17.2 -> satisfiable by kriswallsmith/buzz[0.17.2].
- ezsystems/ezpublish-kernel v7.3.0 requires kriswallsmith/buzz ^0.17.2 -> satisfiable by kriswallsmith/buzz[0.17.2].
- Conclusion: don’t install kriswallsmith/buzz 0.17.2
- Installation request for ezsystems/ezpublish-kernel ~7.3.0 -> satisfiable by ezsystems/ezpublish-kernel[v7.3.0, v7.3.1, v7.3.2, v7.3.1.1].


#3

Hi there, I solved MY problem by casting ezplatform/vendor/hwi/oauth-bundle/OAuth/ResourceOwner/AbstractResourceOwner.php line 253 to string.