eZ Platform Discussions

Does legacy-bridge can be use on front


#1

Hello everyone,

I have to do a version upgrade of php 5.6 to php 7.?

My site is in eZ5 2014.11 in legacy mode.

ez 2014.11 is not compatible with php 7.?

So I need to upgrade my eZ5 version to eZPlatform.

But as everything is in legacy mode, can I do it with eZPlatform 1.13 + legacy-bridge?
Is it better for me to get on the eZPlatform 2? (Still with legacy-bridge)

Merci pour votre aide.


#2

Hi @remy_php!

Legacy mode should work for both 1.13 and 2.0.

It is advisable, however, to start implementing the site with the new stack on latest eZ Platform and use legacy bridge only for legacy admin, in order to minimize technical debt that comes with developing in legacy.


#3

Keep in mind there are 2 ways to run legacy on a certain siteaccess:

More info here: https://doc.ez.no/display/EZP/Legacy+code+and+features#Legacycodeandfeatures-LegacyMode


#4

Thank you for your quick answers!

I have difficulties to understand. The legacy-bridge is directly available? or should I install it in addition to eZPlatform?

I installed eZPlatform 1.13 with the download option: https://www.ezplatform.com/#download-option

But the legacy_mode parameter does not seem valid

ezplatform.yml

ezpublish:
    system:
      client_group: # group with all my siteacces
        legacy_mode: true

[Symfony \ Component \ Config \ Context \ Exception \ InvalidConfigurationException]
Unrecognized option “legacy_mode” under “ezpublish.system.client_group”

So I added the legacy-bridge

php composer.phar require --no-update ezsystems / legacy-bridge

composer.json

"ezsystems/legacy-bridge": "^2.0"
"ezsystems/ezpublish-kernel": "~6.13.0",

But I have an error on the composer update:

php -d memory_limit = -1 composer.phar update

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - ezsystems/legacy-bridge v2.0.2 requires ezsystems/ezpublish-kernel ^7.0@dev -> satisfiable by ezsystems/ezpublish-kernel[7.0.x-dev, 7.1.x-dev, v7.0.0, v7.0.0-beta1, v7.0.0-beta2, v7.0.0-beta3, v7.0.0-rc1, v7.0.1] but these conflict with your requirements or minimum-stability.
    - ezsystems/legacy-bridge v2.0.1 requires ezsystems/ezpublish-kernel ^7.0@dev -> satisfiable by ezsystems/ezpublish-kernel[7.0.x-dev, 7.1.x-dev, v7.0.0, v7.0.0-beta1, v7.0.0-beta2, v7.0.0-beta3, v7.0.0-rc1, v7.0.1] but these conflict with your requirements or minimum-stability.
    - ezsystems/legacy-bridge v2.0.0 requires ezsystems/ezpublish-kernel ^7.0@dev -> satisfiable by ezsystems/ezpublish-kernel[7.0.x-dev, 7.1.x-dev, v7.0.0, v7.0.0-beta1, v7.0.0-beta2, v7.0.0-beta3, v7.0.0-rc1, v7.0.1] but these conflict with your requirements or minimum-stability.
    - Installation request for ezsystems/legacy-bridge ^2.0 -> satisfiable by ezsystems/legacy-bridge[v2.0.0, v2.0.1, v2.0.2].

What do I have to do ?


#5

You should use Legacy Bridge in ^1.4 version for eZ 6.13. Legacy Bridge ^2.0 is only for eZ kernel 7.0 :slight_smile: