eZ Platform Discussions

Customizing the front page not working - Ez Platform tutorial


#1

I’ve installed the Ez Platform demo, following the instructions found on Github:

/usr/bin/composer.phar create-project --keep-vcs ezsystems/ezplatform

php -d memory_limit=-1 app/console ezplatform:install --env prod clean

and then generating the vhost file with the command and the nginx template.

When trying to customize the front page, nothing works, I don’t see any change on my home page and I’m stuck with the “Welcome to eZ Platform” page.

I’ve updated app/config/ezplatform.yml:

system:
   site_group:
        cache_pool_name: '%cache_pool%'
        var_dir: var/site
        languages: [eng-GB]
        content:
            default_ttl: '%httpcache_default_ttl%'
        http_cache:
            purge_servers: ['%purge_server%']
        content_view:
            full:
                home_page:
                    template: 'full/home_page.html.twig'
                    match:
                        Id\Location: 2

and updated the app/Resources/views/full/home_page.html.twig with the Hello World Div.
I’ve also cleared the cache using the console command.

Any help is appreciated, thanks in advance.


#2

Hello @MortisQc.
Which version of eZ Platform are you using? Judging by the configuration it’s version 1. However what you should get right now when executing composer create-project is version 2.5.1, so something doesn’t add up here for me.

Anyway I’ve checked both v2.5.1 and latest release of v1.13.4.1 with the given content_view configuration and everything is working as it should.

Make sure though to clear cache for proper environment. If you neither didn’t set SYMFONY_ENV=prod environment variable nor appended --env=prod to your clear:cache Symfony command, you’ve cleared dev env by default. The environment you’re clearing cache for must match environment you’ve set up for your vhost.

Kind Regards,
Andrew