eZ Platform Discussions

Admin UI bundle not loaded - v1.7 Multisite, Host matching


#1

When upgrading from eZ publish platform 5.4 we checked out 1.7 branch as a first stepstone and applied our multisite configuration. But it seems the admin siteaccesses are not recognized for being admin. Insteadthe standard fallback EzPublishCoreBundle is used. Symony toolbar states that db and siteaccess are chosen correctly.

Maybe someone just sees our mistake.

Config is (dont mind the indentation):

config.yml

imports:
- { resource: default_parameters.yml }
- { resource: parameters.yml }
- { resource: security.yml }
- { resource: env/docker.php }
- { resource: env/platformsh.php }

doctrine:
dbal:
    connections:
        gd_repository_connection:
            driver: pdo_mysql
            host: localhost
            user: ________
            password: __________
            dbname: ___________
            charset: UTF8
        gd_dev_repository_connection:
            driver: pdo_mysql
            host: localhost
            user: _________
            password: _________
            dbname: ___________
            charset: UTF8

endpoints:
    endpoint0:
        dsn: %solr_dsn%
        core: collection1
connections:
    default:
        entry_endpoints:
            - endpoint0
        mapping:
            default: endpoint0

stash:
default_cache: cachegddev
caches:
    default:
        drivers: [FileSystem]
        FileSystem: ~
        inMemory: false
        registerDoctrineAdapter: false
    cachegd:
        drivers: [FileSystem]
        FileSystem: ~
        inMemory: false
        registerDoctrineAdapter: false
    cachegddev:
        drivers: [FileSystem]
        FileSystem: ~
        inMemory: false
        registerDoctrineAdapter: false
       # On Windows, using FileSystem, to avoid hitting filesystem limitations
        # you need to change the keyHashFunction used to generate cache directories to "crc32"
        # FileSystem:
        #    keyHashFunction: crc32
# Disable tracking of cache values to avoid large disk use when using web profiler
tracking_values: false

framework:
esi:             ~
translator:      { fallback: "%locale_fallback%" }
secret:          "%secret%"
router:
    resource: "%kernel.root_dir%/config/routing.yml"
    strict_requirements: ~
csrf_protection: ~
form:
    csrf_protection:
        enabled: true
        # Note: changing this will break legacy extensions that rely on the default name to alter AJAX requests
        # See https://jira.ez.no/browse/EZP-20783
        field_name: ezxform_token
validation:      { enable_annotations: true }
# Place "eztpl" engine first intentionnally.
# This is to avoid template name parsing with Twig engine, refusing specific characters
# which are valid with legacy tpl files.
templating:      { engines: ['twig'] } #assets_version: SomeVersionScheme
default_locale:  "%locale_fallback%"
trusted_hosts:   ~
session:
    # handler_id set to null will use default session handler from php.ini
    handler_id:  ~
    # Note: eZ Publish also allows session name and session cookie configuration to be per SiteAccess, by
    #       default session name will be set to "eZSESSID{siteaccess_hash}" (unique session name per siteaccess)
    #       Further reading on sessions: https://doc.ez.no/display/EZP/Session
fragments:       ~
http_method_override: true

# Twig Configuration
twig:
debug:            "%kernel.debug%"
strict_variables: "%kernel.debug%"

# Assetic Configuration
assetic:
debug:          "%kernel.debug%"
use_controller: false
bundles:        [gdBundle]
#java: /usr/bin/java
filters:
    cssrewrite: ~
    #closure:
    #    jar: "%kernel.root_dir%/Resources/java/compiler.jar"
    #yui_css:
    #    jar: "%kernel.root_dir%/Resources/java/yuicompressor-2.4.7.jar"

# Swiftmailer Configuration
swiftmailer:
transport: "%mailer_transport%"
host:      "%mailer_host%"
username:  "%mailer_user%"
password:  "%mailer_password%"
spool:     { type: memory }

ezplatform.yml

 ezpublish:
 # HttpCache settings, By default 'local' (Symfony HttpCache Proxy), by setting it to 'http' you can point it to Varnish
http_cache:
    purge_type: %purge_type%

# Repositories configuration, setup default repository to support solr if enabled
repositories:
    gd_repository:
        storage:
            engine: legacy
            connection: gd_repository_connection
        search:
            engine: %search_engine%
            connection: gd_repository_connection
    gd_dev_repository:
        storage:
            engine: legacy
            connection: gd_dev_repository_connection
        search:
            engine: %search_engine%
            connection: gd_dev_repository_connection

# Siteaccess configuration, with one siteaccess per default
siteaccess:
    default_siteaccess: gd_dev
    list: [gd,gd_admin,gd_dev,gd_dev_admin]
    groups:
        gd_group: [gd,gd_admin]
        gd_dev_group: [gd_dev,gd_dev_admin]
        admin_group: [gd_admin,gd_dev_admin]
    match:
        Map\Host:
            www.gd.de: gd
            admin.gd.de: gd_admin
            dev.gd.eu: gd_dev
            admin.dev.gd.eu: gd_dev_admin
            migration.gd.eu: gd_dev
            admin.migration.gd.eu: gd_dev_admin

# System settings, grouped by siteaccess and/or siteaccess group
system:
    gd_group:
        repository: gd_repository
        languages: [ger-DE]
        var_dir: var/gd
        cache_pool_name: 'cachegd'
    gd_dev_group:
        repository: gd_dev_repository
        languages: [ger-DE]
        var_dir: var/gd_dev
        cache_pool_name: 'cachegddev'